##Google Analz## ##Microsoft## ##Googel## Swanand: September 2017

Thursday 14 September 2017

FreeNAS LACP and Cisco Switches

&

I’m going to demonstrate how to setup link aggregation (LAGG) on FreeNAS 9.3 using Cisco switches. Aggregation is a method of bonding multiple ethernet links together to provide additional bandwidth and redundancy.

FreeNAS supports several different protocols for LAGG but LACP is the most robust option. LACP is a negotiated protocol that works by exchanging frames with the peer to automatically bundle multiple links together.

If you do not have a Cisco switch you can still use LACP as long as your switch supports IEEE 802.3ad. If it does not support the protocol then you will need to use one of the other protocols such as load balance, or round robin.

On Cisco Switch:

Assuming that you have 2 Stack Cisco 3750 switches and ports of Freenas are connected on G1/0/19 and G2/0/19

int Gi2/0/19
description NAS2 LAGG – 3 – VLAN300
switchport access vlan 300
switchport mode access
channel-group 3 mode active
channel-protocol lacp

int Gi1/0/19
description NAS2 LAGG – 3 – VLAN300
switchport access vlan 300
switchport mode access
channel-group 3 mode active

channel-protocol lacp

Now Create Port Channel group.

interface Port-channel3
description NAS2 LAGG Group VLAN300
switchport access vlan 300
switchport mode access
no shut

Volla!!!!! you are done with the Switch Configuration
To verify the status of each of the individual ports in the bundle run the command ‘show etherchannel port-channel’, each of the ports should have an active status.

Now on the FreeNAS Device configure Link Aggregation with LACP protocol and you are good to go.

Redundancy and Failover Testing

Besides increased bandwidth one of the benefits of using LAGG is it ensures redundnacy in the event of a loss of link on a member. To test the failover capabilities I started a continuous ping to the FreeNAS IP address then pulled out one of the cables. The port channel only dropped one packet before re-converging, not bad!

If your building a high availability NAS then you can see the importance of implementing link aggregation to maintain up-time.



Wednesday 6 September 2017

OSMC Media Center and NAS using Raspberry Pi


Today we are going to go through the steps of configuring OSMC Media Center, which can be controlled using your android or IOS device as a remote.

To create OSMC Media Center you will require:

  • Raspberry Pi
  • Keyboard and mouse to connect to the Raspberry Pi
  • External USB hard drive one or two, depending upon the grade or normal configuration
  • An android mobile so that you can download and install the App which will act as a remote
  • A 5 volt micro USB charger that this could be your android mobile charger, but make sure it gives at least 2000milliamps of power.
  • HDMI wire that connects to your TV from the Raspberry Pi
So gather all this material and lets go ahead and create this OSMC Media Center.

Preparing the SD Card.

First, we need to format our micro SD card properly. Head over to the SD association website and download the application. Installing the application is a straight forward process. Insert your SD card into your card reader. In the SD formatter app, choose the correct SD card, change to overwrite format and proceed. Once formatting is done, you get a confirmation.

Which Media Center to choose?

There are two types of operating systems available that you can install in your Raspberry Pi to convert into a media center. One is called as Kodi and another one is called as OSMC. The main difference between Kodi and OSMC is that Kodi is not a Linux flavour. Kodi is built from ground up, so you cannot give any Linux commands to it like sudo or apt-get. But in our project we need to create a network attached storage system which requires a lot of Linux comments. So OSMC is the best choice. Obviously OSMC runs a Linux OS, on top of which Kodi runs. So you get the goodness of Linux along with the goodness of Kodi. Apart from all these things I just feel OSMC has beautiful visuals.

Change settings - Allow downloaded apps from anywhere.

Change settings – Allow downloaded apps from anywhere.

Installing OSMC Media Center

Download the installation application for your OS and get going with the setup process. Sometimes your MAC does not allow downloaded apps to be installed in that case change your settings in the ‘Security & Privacy‘ page of ‘System Preference‘. Make sure to choose anywhere.

Choose the language and the board

Choose the language and the board

Choose the language and your version of the Raspberry Pi board

Select the stable version of OSMC

Select the stable version of OSMC

R3 is the latest stable build of OSMC Media Center at the time of making this video.
Then burn the files to the SD card. Choose the connection type; mine is wired. We will configure the network later. Choose the correct SD card and let the app download OSMC and burn it to the SD card.

Insert the SD card and all other necessary connections to the Raspberry Pi

Insert the SD card and all other necessary connections to the Raspberry Pi

After installation is complete, quit the application and eject the card. Now insert the SD card on the raspberry Pi and connect the Ethernet wire, HDMI cable, power source, keyboard and mouse.

Configure OSMC Media Center to your needs

If you see the rainbow screen once you power ON your Raspberry Pi then all is good. OSMC will start installing automatically.

Configure the OSMC

Configure the OSMC

Time to configure your OSMC Media Center. Select your language and go through the basic setting process.

Set the manual IP address for the Raspberry Pi

Set the manual IP address for the Raspberry Pi

Now click on My OSMC then select network and secure IP address manually this is necessary so that when you restart your Raspberry Pi the IP address remains the same.

Setting up the NAS

To get to the terminal, let’s exit OSMC. The login and password is “osmc” in lower case without quotes. First lets install NTFS package to manage the hard disk.

sudo apt-get install ntfs-3g
Using F disk we list all the drives connected to Raspberry Pi. I have already connected my 2 TB hard drives to the Pi. You can see them listed as SDB and SDC. SDA is a windows hard disk I connected to test something else.

sudo fdisk -l
Check if the drives are connected properly.

Check if the drives are connected properly.

To mount these two hard drives to the OS we need to create two directories I named them USBHDD1 and USBHDD2.

sudo mkdir /media/USBHDD1
sudo mkdir /media/USBHDD2
Then I mount the hard disk I want using the mount command. Here SDA1 and SDB1 are the partition names inside the SDA and SDB drivers that we saw earlier.

sudo mount -t auto /dev/sda1 /media/USBHDD1
sudo mount -t auto /dev/sdb1 /media/USBHDD2
To keep things organized I created a ‘shares’ folder inside each USB folder. This folder will be the shared folder from each drive which can be accessed from other PC’s in your network.

sudo mkdir /media/USBHDD1/shares
sudo mkdir /media/USBHDD2/shares
Let’s install Samba. Samba is a file sharing application, which can help other PC talk to your Raspberry Pi.
sudo apt-get install samba samba-common-bin
If you get an error it means that we need to update our OS and we do that using this command.
sudo apt-get upgrade
Again, try installing Samba and this time. Success!
Let’s make a copy of the Samba configuration file before editing.

sudo cp /etc/samba/smb.conf /etc/samba/smb.conf.old
Then use the nano editor to make changes to the configured file.

sudo nano /etc/samba/smb.conf
Scroll down to the end of the page and create share folder names. The name you give inside the square brackets will be the names shown in other PC’s. When you access this Raspberry Pi. Make sure read only set no. After making changes, press Ctrl X to close the nano editor, Press “Y”to save the changes.

Give the folder a recognisable name.

Give the folder a recognizable name.

Restart Samba to take effect of the changes added to the configured file.

sudo /etc/init.d/samba restart
Let’s create a user and a password and add it to Samba. This username and password will be asked every time you want access the share folder from other PC’s. I have set “fatlady” as the username

sudo useradd fatlady -m -G users
sudo passwd fatlady

sudo smbpasswd -a fatlady
All set. Let’s test it on by copying files into the shares folder. and sure enough, we see it displayed here in the directory listing.

The test file copied is displayed.

The test file copied is displayed.

To automatically mount both the hard drives to OS, let’s write a few lines of code.Open fstab in nano editor.

sudo nano /etc/fstab
Write these lines of code. Save and close the nano editor.

/dev/sda1 /media/USBHDD1 auto noatime 0 0
/dev/sdb1 /media/USBHDD2 auto noatime 0 0
We install rsync. R sink is a powerful tool used to make a mirror copy of a folder or a drive to another.

sudo apt-get install rsync
Restart OSMC and go to file manager inside settings to check if you can see your mounted drives.

Installing the Mobile App

Now to install the mobile app. Head over to Google play and search for Kodi. Select the correct app and install it to your device.

Kodi remote app on Play Store

Kodi remote app on Play Store

Hope you enjoyed this. Now you can have your own OSMC Media Center and watch all those beautiful movies & TV Shows from one place.



Source:-http://www.mediamilan.com/tutos/osmc-media-center-and-nas-raspberry-pi/

Tuesday 5 September 2017

How to Install Kodi on Raspberry Pi 3 (Guide)

Kodi is everyone’s favourite media streaming solution and the Raspberry Pi is the geek’s playground for making several cool projects. You can always purchase a dedicated Kodi box (which itself is not much different from an Android TV box), but of course, it doesn’t satisfy the geek within you. Moreover, you can use a Raspberry Pi to make several other projects, besides just installing Kodi. Having said that, if you’re looking for a simpler, more user-friendly solution, you’re better off purchasing a Kodi box. However, if you love tinkering around and don’t mind learning a bit in the process, then you’re in for a treat. Today, I’ll show you how to install Kodi on Raspberry Pi 3 using OSMC:-

Install Kodi on Raspberry Pi 3

Things You Will Need

  • A Raspberry Pi with power source
  • microSD card with adapter/USB drive
  • USB keyboard
  • HDMI cable
  • Raspberry Pi case (While not absolutely necessary, I definitely recommend getting one.)

Install OSMC on a microSD card

Download OSMC installer for your operating system. OSMC is a Debian-based OS with Kodi installed and the installer is available for Windows, macOS and Linux.
  • The first time you open the OSMC installer, you should be greeted with a welcome message. Select English (there’s no other language listed!) and Raspberry Pi 2/3 in the subsequent box and click on the next arrow.
 
  • Select the version of OSMC you want to download. “2017.02-2” is the latest version as of writing, but if there’s any update available, download it instead, by all means. Click on the next arrow to continue. The installer will attempt to download the selected version from the Internet in the next step. Alternatively, you can first download the disk image from their website and tick the “Use a local build on my computer”.

  • Plug-in the card reader with a microSD card in the USB port of your laptop/desktop. Select the “On an SD card” option when it asks where to install OSMC and click the next arrow.

  • In this step, select your network connection type. If you’re using Ethernet, select “Wired connection” and if you’re using WiFi, select “Wireless”. Click the next arrow to continue.

  • If you opt-in for “Wireless”, enter your WiFi name and password credentials and click the next arrow.

  • Select the device that appears and click the next arrow. Please be warned that installing OSMC will format the microSD card, so make sure to backup any important files. In the rare case that you’re unable to see any device, make sure that the card reader with a MicroSD card is connected to your laptop/desktop and formatted properly.

  • (Read!) and accept the license agreement and continue to the next screen.

  • The download (~175 MB) will now begin and should be completed in a few minutes, depending on your network connection. Upon completion, you’re ready for show time! (or so it should say, at least!)

At this point, you’ve successfully completed the software installation process. Now, let’s move on to the hardware part.

Make the Required Hardware Connections

  • Put the microSD card into the Raspberry Pi’s card slot. Connect the USB keyboard and power supply to the Raspberry Pi.
  • Connect the HDMI cable to an external display/TV and switch on the power supply. You should now see the OSMC window and the initialization should be complete in a few seconds.

  • You should see a fairly basic start-up wizard on the first start. Use your keyboard to navigate around the interface and select things. Just select your preferred language, time zone, device name and other similar things.




You have the option to select between two pre-installed themes: Kodi’s Krypton’s new default theme, Estuary or OSMC skin. Of course, you can download and apply several other themes later.
So that is it! You’ve successfully installed Kodi on the Raspberry Pi 3.


As you can see, installing Kodi on Raspberry Pi using OSMC is quite easy. If for some reason, you’re looking for an alternative to OSMC, you can also try OpenELEC.

Using Kodi on the Raspberry Pi 3

In my limited testing, I was able to get Kodi working flawlessly on the Raspberry Pi 3. The Pi’s 1.2 GHz CPU and 1 GB of RAM made for a smooth experience on Kodi. I was able to connect to the WiFi and browse for add-ons. The Pi also has an Ethernet port, so you can do with wired Internet connection, too. There might be occasional stutter in the interface when you’re trying to play a high-quality video, but I experienced little to no frame rate drops. While I didn’t notice any abnormal temperature rise, some people in the community certainly have. You can always monitor the Pi’s temperature by going into Kodi’s settings. Also, make sure to have a case that doesn’t obstruct the air circulation. If nothing helps, you may as well try using a heat sink.
If you are new to Kodi, you can check out our detailed article on how to use it to get started with it.

 

Install and Use Kodi on Raspberry Pi 3 Easily

Installing Kodi on a Raspberry Pi gives you a powerful media streaming solution at an affordable price. Well, if you have a Raspberry Pi 3 or any other version with you and you use Kodi a lot, it should be a good idea to create your very own Kodi box using Raspberry Pi. So, have you tried installing Kodi on a Raspberry Pi 3? If yes, I’d love to hear about your experience in the comments section below.

Featured post

Vicidial With WebRTC

Vicidial With WebRTC VICIDial is well known open source call center software. It has been in use by many small to large scaled con...